Directmail - newsletter template

  • Hallo,


    Ich habe die Direct Mail Extension installiert und möchte Newsletter versenden. Bisher funktioniert auch alles bestens - nur kann ich das Layout des Newsletters nicht ändern.
    Der Constant editor bietet mir nicht genug Möglichkeiten, da ich den Grundlegenden Aufbau des Newsletters ändern möchte. Auch die css-datei würde ich geren ändern. Ich kenne zwar den Pfad der Template-datei, kann aber über den fileadmin nicht darauf zugreifen. (Die Website läuft über einen Server, auf dem mehrere Projekte liegen)
    Ich könnte jedoch über den Constant Editor ein neue Datei hochladen, oder?
    Dazu bräuchte ich jedoch die aktuelle(n) Datei(en) als Vorlage.


    Grüße Sebi

  • Danke, das Tutorial ist prima - das beantwortet gleich ein paar andere Fragen:)


    Bei folgendem Schritt komme ich jedoch nciht weiter:

    Zitat

    Vorerst kopieren wir das Template für die Newsletteranmeldung (typo3conf/ext/direct_mail_subscription/pi/fe_admin_dmailsubscrip.tmpl) nach fileadmin/templates/newsletter_subscription.html, so das wir es später bearbeiten können.


    Benötige ich dazu einen FTP-Zugang?

  • Es ist ein neues Problem aufgetreten:
    Der Versand funktioniert nicht mehr!
    Bevor ich am Template gabstelt hatte ging alles.
    Jetzt wähle ich "versand dieser Seite erstellen", wechsel dann zu empfängerliste, klicke auf den Titel der gewünschten Gruppe, gehe dann über das Dropdown weiter zu Versandstatus um den Versand anzustoßen - der taucht dort aber nicht auf.


    Über das List-Modul sehe ich, dass ein Versandobjekt erstellt wurde.
    Dabei ist aber die Startzeit und die Endzeit festgesetzt auf 1970 ohne dass ich das ändern könnte.


    Wie komme ich da weiter?

  • Ah! Danke:)


    In der Mail ist jetzt aber kein Inhalt drin, obwohl die Seite beim Preview Inhalt hat. :confused:


    edit:
    im Preview ist auch nur dann Inhalt zu sehen, wenn ich eine FE-Benutzergruppe simuliere.

  • Der Versand funktioniert jetzt bestens - das heißt, es kommt etwas an... aber ohne inhalt:confused:


    Bei der Bearbeitung wird alles korrekt angezeigt, es gibt keine Fehlermeldungen beim Versand - nur die mail ist leer (bis auf den Betreff und einige Dateien im Anhang: 4 dateien mit name "noname")


    Ich bin leicht irritiert, da ich schon mal mails MIT inhalt verschickt habe...
    Durch die änderung des templates kann dies eigentlich nciht entstanden sein, da die anzeige im backend funktioniert.


    Grüße sebi

  • Ein Newsletter hat ein eigenes Template. hast Du Dir mein Tutorial angeschaut?
    http://www.sk-typo3.de/Einrich…sletters-mit-D.149.0.html


    ich nutze mal den Thread für meine Frage weil ich mich so schön auf das Tutorial beziehen kann.


    Ich hänge momentan hier fest:
    Es müsste ein neuer Datensatz im SysOrdner Abonnoments gelandet sein, der versteckt ist - wenn wir unsere Email erhalten haben und auf den Aktivierungslink geklickt haben, so wird der Datensatz sichtbar.


    ich kann mich anmelden - Mail wird verschickt - ich sehe aber keinen Datensatz unter im Sysordner Abonnements.


    nutze allerdings die aktuelle T3 Version - kann es daran liegen?