Kompatibilität von PHP- und Wordpress-Versionen

Liebe Traumprojekt Benutzer,

wie Ihr sicherlich bemerkt habt, ist das Traumprojekt eine gewisse Zeit nicht erreichbar gewesen.
Der Hauptgrund dafür ist, dass es einen Betreiberwechsel gegeben hat.
Nähere Info´s dazu bekommt Ihr in einem separaten Thema.

Bitte gebt uns etwas Zeit den Wechsel reibungslos über die Bühne zu bringen.

Mit freundlichen Grüßen Traumprojekt-Team
  • Huhu :)

    Ich such mir grad nen Wolf und finde es nicht - eine Bekannte hat die Meldung bekommen, daß demnächst PHP 5.2, 5.3 und 5.4 abgeschaltet wird. Bei ihr läuft Wordpress 3.8.1. Muss sie zwingend aktualisieren? Plugins sind unproblematisch, Theme ist wohl eine Eigenbau-Variante von twenty twelve.
    Daß sie aktualisieren sollte, ist klar. Aber muss sie? ;)

    Liebe Grüße
    Mieze

  • Was will sie dann nehmen? PHP 7 ist in sehr vielen Teilen nicht abwärtskompatibel. Sehr wahrscheinlich klappt das dann nicht.


    PHP 5.5, 5.6 könnte noch klappen.


    Die Änderungen der Versionen findest du hier https://wiki.php.net/rfc#php_56


    Hier siehst du die deprecated features http://php.net/manual/de/migration55.deprecated.php

    und hier, was inkompatibel ist: http://php.net/manual/de/migration55.incompatible.php



    Ansonsten hilft dieses Plugin evtl. weiter https://de.wordpress.org/plugins/php-compatibility-checker/

  • Vielen Dank :)

    Ich hätte schwören können, daß es da eine Liste gab. Sowas wie "Wordpress 3.5 läuft mit PHP x,y,z, Wordpress 3.6 läuft mit ...". Aber vielleicht verwechsel ich das auch gerade mit Typo3 *kratzamkopp*

    Ich hab mich gerade selbst mal durch ihr Provider-Backend gewühlt. So wie es aussieht, kann sie 5.5 wählen. Und wenn ich es richtig sehe, kann sie zur Zeit dann auch wieder auf 5.2 zurückstellen. Dann müsste sie ja sehen, ob es klappt .. wenn nicht, könnte dann evtl. das plugin zum Einsatz kommen.


    Ich möchte da nicht zuuu viel Zeit investieren. Es ist nur ne Bekannte, und Geld bezahlen wird sie nicht.

  • Laufen tut es wohl schon noch, aber es wird nicht mehr supportet:

    Zitat

    Note: If you are in a legacy environment where you only have older PHP or MySQL versions, WordPress also works with PHP 5.2.4+ and MySQL 5.0+, but these versions have reached official End Of Life and as such may expose your site to security vulnerabilities.

    https://wordpress.org/about/requirements/


    Wenn es all-inkl ist (die Meldung habe ich auch bekommen), dann kann man zum Testen PHP hoch- und wieder runtersetzen. Ab dem angekündigtem Datum geht dann aber nur größer v5.5.

    Grüße vom Griechen,
    Cybergreek!

  • Ich denke die meisten Webhosting Provider bieten die Möglichkeit für Testzwecke die php Version hoch unter runter zusetzen.
    Bei HostEurope, 1&1 und Domain-Factory habe ich dies bereits für Freunde und Bekannte gemacht.

    Gruß HMV

  • alexhell : bin ich tatsächlich auch drüber gestolpert. Aber ich dachte, ich habs bestimmt falsch verstanden ;)

    @HMV: die Einstellung habe ich mittlerweile auch gefunden. Aber da soll sie lieber selbst draufklicken. Zusätzlich zu "Ich bin doch nicht doof und zahle viel Geld für Internetseiten!" und "ist doch nur ein Hobby für Dich, Du bist ja schließlich kein richtiger Profi" befürchte ich ein "da läuft was nicht, das muss deine Schuld sein, Du hast da rumgeklickt!" ;)