template - bilder lokal ersichtlich, online aber nicht

  • hallo


    fact:
    hebe ein template übernommen (gratis aus dem netz) und nun abgeändert.


    eingefügt in dreamweaver funktioniert alles toll...


    problem:
    nun lade ich das teil hoch und die "online-version" finde die gif`s nicht, oder kurz gesagt: das template...


    was ich vermute (als fireworks-anfönger) ist, dass die verlinkung einfach nicht stimmt :
    <td rowspan="2" colspan="3"><a href="file:///d|/Dokumente%20und%20Einstellungen/colocator/Eigene%20Dateien/Eigene%20Webs/bluewinTV/skyline%20group%20sample%20site/index.html"><img name="logo" src="file:///d|/Dokumente%20und%20Einstellungen/colocator/Eigene%20Dateien/Eigene%20Webs/bluewinTV/skyline%20group%20sample%20site/images/logo.gif" width="222" height="57" border="0" alt=""></a></td>



    wo bitte muss/soll/kann ich ändern, dass die "online-version" nicht den ganzen pfad c:/eigenedokument/etc sucht, sondern nur; ".../images/bild.gif???



    ich weiss noch von frontpage zeiten (ja, bitte jetzt kein kommentar zu MS FP ;) dass auch dieses toll die macke hatte, unmengen von falschen url`seinzufügen...



    vielen dank für tipps


    michael

  • Hast du denn in Dreamweaver überhaupt eine Site eingerichtet? Wenn nicht, richte erstmal eine ein und änder dann das Template. Templates (*.dwt) sollten auch in gleichnamigen Ordner deiner Site gespeichert werden. Das passiert in der Regel bei erneutem abspeichern als Vorlage. Ohne Site kann Dreamweaver Pfade nicht verwalten und wird dir immer zu gunsten der Offline funktionalität ein "file:///" vorsetzen.


    Gruß Andi

    Nichts ist unmöglich...Fireworks
    Private Hilfe nötig? Kein Problem! Preise auf Anfrage!
    Was ist eine Leistungssteigerung um 85%? Ich finde dazu keine Übersetzung!


    PS. Ich kenn einen guten Optiker, der bringt auch dem letzten Analphabeten das Lesen bei.

  • hy andi, danke für die schnelle antwort.


    das *.dwt ist im selben ordner.
    nun hab eine neue seite zum testen kreiert. ich bitte dich, mein step-by-step vorgehen zu korrigieren, oder zu schildern, wie ich das richtig machen kann. (denn, so blöd bin ich eigentlich nicht)


    das template existiert ja bereits (noch in einem anderen ordner):


    1. dreamweaver- new site.
    2. modify/templates/ apply template to page/
    3. save as template (im ordner, wo auch die html`s sind)
    4. save "as index" .
    5... und nun ?


    danke für tipps, ich check`s echt nicht mehr ;)

  • Hallo Cosmix,


    überprüfe doch mal ob Deine Templates in dem von DW aut. erstellten Ordner "Templates" innerhalb der def. Site liegen.

    Zu den falschen Grafik - Verknüpfungen:

    Vermutlich hast Du im DW die Option für das einfügen von Dateien "Relativ zu Stammordner" aktiviert. DW erstellt dann absol. lok. Pfade.

    Das solltest Du ändern in "Relativ zu Dokument" dies machst Du wie folgt:

    Offne ein Dokument und geh auf den Dialog zum Einfügen von Bildern, dort änderst Du dann die Einstellung wie im angehängten Screenshot.

    Grüße Floh

  • hy floh
    danke.


    problem online version:
    ich habe auf dem webserver alles gelöscht, und nun ohne unterordner (ausser templates, images) direkt ins zuständige directory abgelegt - > resultat, "bilder" werden angezeigt. jedoch die pop-up (menu) - funktion geht noch nicht. (www.303.ch)


    für dein verständins:
    ich habe ein template übernommen (e-mule sei dank) und das ganze bin ich am abändern.
    d.h nun habe ich eine original version(ordner), und ein ordner worin JETZT alles gespeichert werden soll. problem ist ( wie von dir geschildert) dass DW jeweils die falsche "save as" url nimmt, obwohl ich das template aus dem richtigen ordner öffne


    meine abgeänderten dateien (html) sind im richtigen ordner, das template aber im falschen. korrektur manuell ist, das "falsche" dwt in den richtgen ordner zu kopieren...



    wenn ich im DW template save as wähle, habe ich nur diese option:
    (siehe anhang)




    www.303.ch

  • check unbedingt den Screenshot von [art-d-sign]. Hat aber ansich nichts mit file// zu tun. Das sind nur die Verweise Relativ zu Startordner oder Dokument. Startordner-Pfade funktionieren nicht Offline, außer in Dreamweaver oder wenn zufällig die Ordnerstruktur vom Laufwerk zutrifft. Wenn du deine Site also ohne Dreamweaver offline betrachten willst, dann klappt da nix. Deswegen nimm Relativ zu Dokument. Online spielt das dann keine Rolle mehr. Ob Dokument oder Stammordner ist also eher Gewöhnungssache sonst gibts da keinen Unterschied.


    Dann würd ich so vorgehen:


    1. dreamweaver- new site.
    OK!
    2. modify/templates/ apply template to page/
    Nö, noch nicht! Nur Template öffnen, Bildpfade und andere Verweise korrigieren. Dann…
    3. save as template (im ordner, wo auch die html`s sind) Dreamweaver speichert eine Vorlage automatisch in einem Ordner ' Templates'. Ich würde da nicht rumwerkeln und es dabei belassen.
    4. save "as index" .
    Nö! Erst…
    modify/templates/ apply template to page/
    dann…
    save "as index"
    5... und nun ?


    Nix weiter. Vorlage haste geändert, neu abgespeichert und kannst sie normal auf deine Seiten anwenden (Vorlage auf Seite anwenden bzw. apply template to page.


    Gruß Andi

    Nichts ist unmöglich...Fireworks
    Private Hilfe nötig? Kein Problem! Preise auf Anfrage!
    Was ist eine Leistungssteigerung um 85%? Ich finde dazu keine Übersetzung!


    PS. Ich kenn einen guten Optiker, der bringt auch dem letzten Analphabeten das Lesen bei.

  • ups, du warst schneller ;)


    Popupproblem: Es sollte auch die fw_menu.js auf dem Server sein. auch hier Pfade beachten!


    Zitat

    wenn ich im DW template save as wähle, habe ich nur diese option:

    Ist ja korrekt! er speichert automatisch im richtigen Ordner, den er bei Bedarf anlegt. Aber das ist Flohs Sache ;)


    Gruß Andi

    Nichts ist unmöglich...Fireworks
    Private Hilfe nötig? Kein Problem! Preise auf Anfrage!
    Was ist eine Leistungssteigerung um 85%? Ich finde dazu keine Übersetzung!


    PS. Ich kenn einen guten Optiker, der bringt auch dem letzten Analphabeten das Lesen bei.

  • das popup menu funktiniert online noch immer nicht, obwohl ich fw_menu.js in allen erdenklichen ordnern auf dem server transferiert habe..


    muss mich noch ein bisschen damit befassen.
    - aber euch einen lieben dank für die sehr schnelle hilfe, ihr seit super!


    michael

  • so, nur noch als info:


    ich habe euer rat befolgt.
    das problem war dass ich ein "gratis-template aus dem netz" für das weiterbearbeiten auf meinen pc kopiert habe, dann jeweils an der kopierten version gearbeitet habe. das dumme war, dass es einen teil beim original bezogen/gespeichert hat, sowie einen teil bei der kopie.


    mein vorgehen: wirklich alles auf dem pc gelöscht, dann nur an einem (1) template gearbeitet. nun funktioniert alles!


    auch die "online" version wird oder würde funktionieren.


    ps. die TP seite ist toll, kompliment. konnte schon viele weitere tipps gut gebrauchen.


    grüsse
    michael