Mit Firefox funktionierts, aber nicht mit IE!?!?

  • Hallo


    Habe ein Problem:


    Habe meine Seite mit einer verschachtelten Tabelle versehen. Bei der äusseren Tabelle ist die Breite auf 100% eingestellt, die innere auf die gewünschte Grösse. Nun klappts im Firefox perfekt, je nach Auflösung verschiebt sich die Tabelle immer schön zentrisch, aber im IE bleibt die Tabelle immer oben links kleben. Habe es schon versucht, indem ich der Tabelle (äusseren) gesagt habe, sie sei zentrisch... Aber nix, es geht einfach nicht. Es ist mir schon wichtig, dass sie auch im IE richtig dargestellt wird.


    Wäre für jeden Tip dankbar.


    Leider ist die Seit nicht online, kann aber auf Wunsch, den Code posten.


    Danke und Gruss
    GM12

  • Zitat von GM12

    Leider ist die Seit nicht online, kann aber auf Wunsch, den Code posten.

    Ist für ne Ursachenanalyse nie schlecht - so wär's nur ein Rumstochern im Nebel...;)

    Also: der entscheidende Codeschnipsel wäre schon hilfreich...

    Gruß, der Michl



    * * * if you want them to RTFM, make a better FM! * * *

  • Sorry... ;)


    hier ist er:


    <body>
    <table width="100%" border="0" cellspacing="0" bordercolor="#000000" bgcolor="#FFFFFF">
    <tr>
    <td width="598" height="750" align="center" valign="top" bgcolor="#000000"><table width="580" border="0" align="center" cellspacing="0">
    <tr bgcolor="#3A4FAC">
    <th colspan="7" class="Stil18">Fotos</th>
    </tr>
    <tr class="Stil26">
    <td colspan="7">&nbsp;</td>
    </tr>
    <tr class="Stil26">
    <td width="81"><u>Vorrunde</u></td>
    <td width="240">&nbsp;</td>
    <td width="84"><u>R&uuml;ckrunde</u></td>
    <td width="167">&nbsp;</td>
    </tr>
    <tr class="Stil26">
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    </tr>
    <tr class="Stil26">
    <td>16-10-04:</td>
    <td><div align="left">Luzern - Chiasso </div></td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    </tr>
    <tr class="Stil26">
    <td>&nbsp;</td>
    <td><div align="left"></div></td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    </tr>
    <tr class="Stil26">
    <td>09-10-04:</td>
    <td><div align="left">Luzern - Engelberg </div></td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    </tr>
    <tr class="Stil26">
    <td>&nbsp;</td>
    <td><div align="left"></div></td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    </tr>
    <tr class="Stil26">
    <td>02-10-04:</td>
    <td><div align="left">Luzern - Illnau-Effretikon </div></td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    </tr>
    <tr class="Stil26">
    <td>&nbsp;</td>
    <td><div align="left"></div></td>
    <td>&nbsp;</td>
    <td>&nbsp;</td>
    </tr>
    </table></td>
    </tr>
    </table>
    </body>

  • moin GM12


    ungetestet:


    Code
    1. <table width="100%" border="0" align="center" cellspacing="0" bordercolor="#000000" bgcolor="#FFFFFF">
    2. <tr>
    3. <td width="100%" height="750" align="center" valign="top" bgcolor="#000000"><table width="580" border="0" cellspacing="0">


    mfg
    frank

    jedes bit findet seinen weg..........zumeist ;-)

  • GENIAL!!!


    Danke Frank! Wenn du mal in der Schweiz zu Besuch bist, kriegste ein Bier spendiert.


    Vielen vielen Dank


    Gruss GM12

  • inwieweit das ein ie-bug ist, kann ich nicht sagen, aber es liegt an der angabe für "width" in der zelle, in der die andere tabelle ist. die zelle hat eine width von 598 und die tablle eine von 580. insofern ist die tabelle innerhalb der zelle schon mittig positioniert. allerdings zeigt der ie die zelle eben nicht zentriert, sondern linksbündig an.


    nimm das width aus der zelle raus, dann funktioniert es auch im ie.


    gruß
    steffen


    [edit] wieder mal viel zu langsam [/edit]