Gif-ani's bei <a href=> nicht stoppen...

  • hey leute,


    ich habe auf html-seiten animierte gif's und verweise die ein neues fenster öffnen.
    wenn ich auf einen link klicke öffnet sich ein neues fenster, das alte bleibt natürlich stehen. aber die animierten gif's stoppen :-(
    also sprich: wenn ich in der seite auf einen link klicke, dann werden alle animationen auf der seite gestoppt.


    weis jemand ob man das unterbinden kann? ich glaube das passiert _nur_ in NS < version 5.


    beispielseite: http://www.schreckundscholz.de -> auf tschüss klicken. die animation von dem winkenden männchen stoppt sobald man auf das bild in der mitte klickt.


    grüsse,
    thomas

  • hi,


    also technisch gesehen sehe ich da leider keine möglichkeit, denn es gibt meines Wissens nach keine möglichkeit aus rein html auf den loop eines gifs einzuwirken....


    dann habe ich mir mal den QT der zweiten seite (die mit dem bild in der mitte) angeschaut... und folgendes gefunden:


    // Bild preloaden
    bild = new Image();
    bild.src = "bilder/menu2.gif";


    wofür brauchst du das? alles andere ist klar, aber warum lädst du an der stelle die menuegrafik nocheinmal?
    Vielleicht klappt es ja, wenn du diese zeilen wieder rausnimmst?


    mfg dares

    ich bin krebs erregend - wer ist krebs?

  • nun, das ist einfach zu erklären:


    ich möchte, das die animation nicht erst langsam geladen werden muss wenn die "tschüss"-seite aufgerufen wird.
    um dem vorzubeugen, lasse ich die animation preloaden. und zwar in jeder html-datei, weil ich nie sicher sein kann, das die besucher über die startseite kommen (thema bookmarks).
    das ist kein performanceverlust, weil der browser das jeweils aus dem RAM-cache holt.


    technisch gesehen macht es für die animation keinen unterschied.


    grüsse,
    thomas

  • nein, denn das problem ist ein allgemeines problem, nicht nur auf dieser seite.
    das gleiche phänomen tritt ebenfalls auf einer reinen html-seite auf, ohne jegliches javascript oder ähnlichem. das problem scheint vom browser auszugehen, ich hatte gehofft das jemand vielleicht doch eine möglichkeit kennt, das zu umgehen.


    thomas