Beiträge von Andi

    Hi John,


    FormPro oder so ähnlich wäre in Sachen Formular Nachbearbeitung/Scann ziemlich gut. Das soll nur schweine teuer sein:(


    Nochmal zu FW: Um da nicht ganz die Flinte ins Korn zu werfen kannst du, wenn du magst, so ein "schwieriges Formular" bzw. "uninteressante Ausschnitte" davon ja mal bereitstellen. Bissel auf Umwege kann man evtl. mit den Mischmodi noch was zaubern. Das jetzt zu erklären ist bissel blöd, deswegen müsst ichs direkt an einem der Formulare probieren.


    Gruß Andi

    der FW Crack sich hiermit mal meldet liebe Rea:D


    John


    Normalerweise können Grafikprogramme die Sache viel besser lösen als ein Scannertreiber, sind ja schließlich dazu da. Daher hat jedes vernünftige Prog ein paar solcher Farbfilter onBoard. Zum Beispiel wären in FW die Livefilter: Stufen und Kurven gut geeignet. Dort kann man jeweils ganz gezielt die Farbkanäle Rot, Grün und Blau getrennt oder auch zusammen beeinflussen. Der Stufenfilter ist da mehr die gröbere Anpassung und der Kurvenfilter macht richtig gute Feinarbeit.


    Alternativ kann man auch das gesamte Bild in ein Graustufenbild (Filter: Farbton/Sättigung) konvertieren und mit Helligkeit und Kontrast so manche OCR-Software vergageiern. Die Graustufenoption sowie Helligkeit und Kontrast hat in der Regel aber auch jeder poplige Scannertreiber onBoard.


    Der Einsatz der genannten Methoden kann auch auf Scriptbasis erfolgen, so dass mehrere Bilder mit einem Ruck bearbeitet werden (Batchverarbeitung in FW). Natürlich ist jede Automatik immer relativ zu sehen;) Die Sache mit dem Script müssten wir dann hier gesondert ausarbeiten.


    Versuch erstmal ein paar Bilder mit einer der Methoden oder in Kombination passend zu kriegen. Das wäre erstmal die Vorraussetzung für ein vernünftiges Script. Geb wieder Bescheid ob es was bringt;)


    Gruß Andi

    Zitat

    Hier könnte man bestimmt Prima mit mehreren Ebenen Arbeiten, wenn man alle Hintergrund-Objekte z.B. in einer Ebene zusammenfasst und diese Ebene ganz unten anordnet.

    Jaaaaaa, endlich mal einer mit Durchblick:D


    http://andi.creativer.de/tpuser/test.png


    Zum Problem: Auch wenn mans kompliziert macht, das Ergebnis sollte trotzdem nicht so verboten sein. Also teilweise stecken da auch uralte Bugs drin. Ein Rechteck ist von Haus aus gruppiert und damit hat Macromedia in so allerlei Hinsicht Probleme (gehabt:D ). Noch schlimmer wirds, wenn der Pinselstrich auf weich bzw. Antialias steht. Hinzu kommen bei Gif Animationen diverse Optionen (Animationsregister), die die einzelnen Frames automatisch anpassen (wollen). Einfach alles rausnehmen. Diese blöde Ungenauigkeit bei gruppierten Rechtecken bzw. der FW interne Umgang damit ist schon ne (uralte) Sauerei. Das hier war noch das kleinste Übel;)


    Gruß Andi

    Hi tokatci,


    slicen = schneiden richtig;)


    Nun schneidest du aber nicht mit dem Messer oder so. Du musst deine gewünschten Bildteile Segmentieren. Diesen Segmenten kannst du dann auch verschiedene Verhalten wie z.B. Rollover (Bildaustausch) zuweisen. Dann exportierst du das ganze und anhand der Segmente und je nach Exporteinstellung regeneriert dir Fireworks dann entweder gleich eine komplette HTML Datei, oder exportiert dir nur die Einzelbilder, so dass du die mit Hand in dein Projekt einfügen kannst.


    Zum slicen allg. hilft dir vielleicht ein etwas älteres Tut zu FW 4. Da hat sich nicht sonderlich viel geändert zu neuen Versionen, so dass du das leicht auf eine neuere Version ummünzen kannst.


    http://www.traum-projekt.com/t…ks/segmentieren/seite/18/


    Für Rollovereffekte gibts mehrere Möglichkeiten: Du kannst z.B. Kontakt mit F8 in ein Schaltflächensymbol konvertieren und dort hast du verschiedene Register für UP, Down usw, die du nur noch grafisch anpassen brauchst. Hierbei wird das jeweilige Segment und der Rollovereffekt automatisch erstellt. Die Segmentgröße ist hierbei aber meist nicht passend und das änderst du dann im Register aktiver Bereich, den du auf manuell schaltest.


    Ich kenn den Aufbau der PNG jetzt nicht, aber in deinem Fall wäre fürs erste vielleicht besser:


    1. Du gehst ins Framebedienfeld und duplizierst den kompletten Frame (ist arbeitstechnisch nicht optimal, aber geht erstmal).
    2. In Frame 2 machst du grafisch deine Änderungen, wie sie beim Rollover sein sollen.
    3. Nun zeichnest du mit dem Segmentierwerkzeug aus der Werkzeugleiste die Segmente wie gewünscht über deine Links. Hilfslinien helfen dabei!
    4. Pro Segment hast du einen Anfassen in der Mitte. Den fass an und zieh in auf sein eigenes Segment (Du merkst einen kurzen Einraster)
    5. Nach dem loslassen bekommst du einen Dialog und dort wähle Frame 2
    6. In der Leinwandvorschau kannst du das dann testen.


    Ob das ganze dann zu einer sauberen HTML Geschichte wird, ist von der ausgewählten Vielfalt der Exportmöglichkeiten abhängig. Das setzt ordentliches Slicen (Segmentieren) voraus.


    Kommst du mit der Beschreibung halbwegs klar? Ansonsten mach ich dir auch ne kurze Bilddarstellung.


    Gruß Andi

    ...aber ich fuchs mich bestimmt nich stundenlang durch 5 Dateien FW Code und weiß dann gerade mal, um was es genau geht;) Vielleicht nochmal etwas besser/genauer beschreiben, was nun am Ende per Befehl gemacht werden soll! Ich denke das läuft nur in Richtung eigenes Script und das geht am ehesten noch mit der MM Referenz zu FW. Viel Ehrgeiz hab ich aber nich dazu, es sei denn, es is nich viel! Sorry, aber meine überzeugten FW Zeiten sind dank der Anwenderpolitik Macromedias (die heißen jetzt anders:D ) schon lange vorbeicaipi Das zusammenführen wird mit dem Standard Batchzeugs jedenfalls so nicht klappen.


    Gruß Andi

    was meinst du nur mit Formatierung vom HTML Segment?


    Wenn du die Ausrichtung der Inputfelder im IE meinst, dann nimm wieder diese DOC.


    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">


    Wenn dann allerdings diverse CSS Formatierungen - insbesondere Abstände - so gar nicht hinhauen, dann eben wieder die...


    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">


    Gibt auch noch paar mehr davon, aber man kann ja nich alles im Kopf haben.


    Und das: Der / und der \ sind zwei unterschiedliche Zeichen mit unterschiedlicher Bedeutung. IE nimmt das nich so und kann sich denken, dass du den / meinst, obwohl du den \ genommen hast. Firefox sagt sich - ne du, nich mit mir. Da steht der \ und das is nich richtigcaipi Änder das, denn das ist dem IE Wurscht, er nimmt beides.


    Gruß Andi

    Zitat

    Datei -> Batchtkonvertierung -> Dateien auswählen -> hinzufügen -> Zielordner auswählen -> Spezialoptionen -> neue Größe => Start

    Ja eben, genau wie in Fireworks. Mal schön bei der Software bleiben, die nachgefragt wird. Wenn was gar nicht geht, dann kann man immer noch Alternativen vorschlagen!;)


    Gruß Andi

    zu 1. Vermutung:


    Ich versteh zwar nicht den Sinn, warum du eine geladene Seite gleich nochmal laden willst, aber wirst schon deine Gründe dafür haben. Jedenfalls könnte der Fehler sein: Klickst du einmal auf "Neue Bilder" in der Startdatei, dann hast du das richtig verlinkt und die Seite aus /bild/bild.html geht auf und wird im Frameset geladen. Klickst du aber nochmal im Popup der bild.html auf den selben Link, dann befindest du dich ja im Ordner /bild und von dort sucht er wieder einen /bild. Also quasi - /bild/bild/bild.html und das gibts so sicher nicht. Der Link in der bild.html muss also nur auf bild.html zeigen und nicht auf bild/bild.html oder du gehst wieder in deiner Ordnerstruktur zurück. Je nach Struktur also z.B. ../bild/bild.html


    zu 2. Bin auch nicht so proggiefit, aber ich denke das ist falsch...


    "window.open(' bild/bild.html', '_blank'");


    eher so...


    "window.open(' bild/bild.html', '_blank')";


    Gruß Andi

    Zitat

    mit "deinem code" meinte ich den von der beispiel Datei von dir

    Die is OK und völlig ohne <a... irgendwas. Also an der liegts dann wohl nich:D


    Jo, gute Idee mit dem Online! Das macht es auch uns um einiges leichter irgendwelche Fehler zu checken.


    Gruß Andi

    Zitat

    <a href="blablabla"><a href="javascript:;" blablabla"><img blablabla></a>

    Du hast du was total falsch verstanden:D Das ist nicht mein Code gewesen, sondern nur ein vereinfacht dargestellter aus deinem Codesalat. Hab nur nicht dein ganzes Zeugs hier rein kopiert. Richtig lesen!;)


    Welche Browserversion von IE? Zu Lösung echt wenig Infos zum Problem!


    Dein letzteres Problem ist in erster Linie die nicht ordnungsgemäße Segmentierung deiner PNG. Das ist einfach Standard-FW und das kann es 100% besser. Du musst es der Software halt nur mitteilen mit einer ordentlichen Segmentierung! Das macht auch den Code schlanker, übersichtlicher und weniger fehleranfällig!


    Ein Ansatz: IE und Firefox etc. haben unterschiedliche Auffassungen vom einhalten der HTML-Standards. Wenn du z.B. per CSS irgendwas formatierst, dann ergibt das meist genau dieses Problem mit den Abständen usw. Manchmal hilft hier das anpassen der Doc-Deklaration (1 Codezeile einer HTML). Die du drin hast (wenns die aus der Beispieldat ist) dürfte eigentlich schon die richtige sein, weil die das Mango bissel ausgleicht. Da gibts halt so Mischungen zwischen korrekter und kompatibler Anzeige und das ganze ist auch Browserabhängig! Die folgende ist jedenfalls nich so gut:


    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">


    Wenn du natürlich irgendwas total verbasselst, dann hilft auch keine DOC mehr weiter, klar. Nimm dir am besten noch einen Tag Zeit und befass dich mit der Segmentierung in FW. Dann bekommste du auch ordentlichen Code und paar Kleinigkeiten lassen sich schnell mal ausbügeln! Was meinste, was losgeht, wenn du vom Chef aus noch Netscape, Opera und was weiß ich alles berücksichtigen musst? Du legst dich auf die nächsten Schienen mit Standard-FW;)


    Gruß Andi

    also irgendwie sieht das alles komisch aus:D


    In der index find ich die folgenden vereinfacht dargestellten Tags:


    <a href="blablabla"><a href="javascript:;" blablabla"><img blablabla></a>


    Verschachtelte hrefs und dann noch nichtmal korrekt abgeschlossen mit </a>


    Ich denke das funktioniert so nicht.


    Gruß Andi

    Zitat

    Wie meinst du das? Bzw. bist du dir da sicher? Ich mein, das wäre echt so mit das Schlimmste was passieren kann, wenn die Seite nun so garnicht funktioniert...


    Ganz einfach: Auf dem Server funktioniert die Dateiverwaltung - bis auf ein paar kleine Konventionen die evtl. zu berücksichtigen sind - nicht anders als bei dir auf dem Heim-PC. Das heißt, alle Verlinkungen (Pfadangaben im Quelltext) zu Bildern, HTML-Dateien, verwendeten Scriptdateien etc. müssen in der Struktur übereinstimmen. Das kriegst du ohne vernünftige Projektverwaltung nur schwer auf die Reihe.


    Beispiel, warum es online nicht funktionieren wird: Bei dir gibts paar Pfade im Quelltext mit C:\Ordner_sowieso. Auf dem Server gibt es in dem Sinne aber kein c:\Ordner_sowieso. Dort bekommst du "nur" einen Stammordner zugewiesen und von diesem aus baut sich deine Pfadstruktur auf.


    Der Browser sucht beim Aufbau der Seite dann auf dem Server bzw. bei einem anderen User nach c:\sowieso und findet das natürlich nicht und schon geht nichts mehr. Diese Tatsache musst du auf deinem heimischen PC berücksichtigen und dir ebenso einen lokalen Stammordner anlegen. Das kann schon der Ordner auf C:\... sein, aber die Pfadangaben dürfen dann nicht c:\xxx lauten, sondern ausgehend von


    Ordner_sowieso\alle weiteren_Ordner\datei.xxx usw.


    Also der Stammordner ist quasi dein "gedachtes" lokales Laufwerk und nicht direkt das C:\ - Mit der Zeit macht sich bezahlt, wenn du dir eine "immer gleiche Struktur" für alle Projekte angewöhnst.


    Beispiel:


    Projekt 1 auf lokalem Laufwerk z.B. C:\
    Stammordner\index.html (im stammordner folgen alle weiteren)


    html\weitere
    images\
    css\
    png\


    Projekt 2 auf lokalem Laufwerk z.B. C:\
    Stammordner\index.html (im stammordner folgen alle weiteren)


    html\weitere Ordner
    images\
    css\
    png\


    Dann fällt dir auch eine Verwaltung ohne Dreamweaver nicht schwer. Das alles ist auch wichtig bei der Arbeit mit Vorlagen etc. Du machst dir einen Ast mit "willkürlichen" Strukturen!


    Ich will das jetzt nicht weiter vertiefen, aber du solltest als nächstes unbedingt eine Site mit Dreamweaver einrichten bzw. dich damit befassen. Du brauchst dir in der Regel dann keine Gedanken mehr über nicht funktionierende Pfade zu machen, weil Dreamweaver das automatisch verwaltet.


    Natürlich kanns du das auch ohne Dreamweaver bewerkstelligen, aber das ändert nichts an der Tatsache, dass du ohne vernünftige Projektstruktur nicht fertig wirst! Bedenke, dass die Geschichte später ja auch mal ohne großen Aufwand gepflegt werden soll und du nach einem halben Jahr Projektruhe kaum noch Überblick darüber haben wirst. Dann vergeudest du viel Zeit mit sinnlosem rumgesuche und anpassen.


    Zu deinem letzteren Problem evtl. Quelltext, aber du könntest vielleicht schon eine Ursache in der obigen Erklärung finden.


    [edit]Deine Online Site ist quasi ein 1 zu 1 Spiegelung deiner Offline Site. Hilft vielleicht besser das ganze zu verstehen.[/edit]


    Gruß Andi

    richtig, nur blau und orange. Ich versuchs mal näher zu erläuterncaipi


    1. die Hintergrundbilder haben einen Verlauf von hell nach dunkel und sind 1000 px hoch. Die dunkelste Stelle (Farbe) ist dann bei 1000 px -OK?
    2. Bei Höhe 1000 angekommen, würde ein Hintergrundbild normalerweise wiederholt werden, also wieder von hell nach dunkel verlaufen und das würde man sehen, weil die hellste Stelle dann wieder ab 1001 px losgeht usw. -OK?
    3. Damit das nicht passiert und das Hintergrundbild nicht zig tausend Pixel hoch sein muss, hab ich einfach das Hintergrundbild per CSS nach unten nicht wiederholen lassen.
    4. Nun hört es ja bei 1000 px auf und wird nicht wiederholt. Man sieht dann nicht mehr das Hintergrundbild ab 1001 px, sondern den Hintergrund der Tabelle, wofür das Hintergrundbild definiert ist. Hat die Tabelle gar keine Hintergrundfarbe, dann sieht man eben den Seitenhintergrund durch. Also geb ich der Tabelle einfach die Verlaufsfarbe, welche bei ihrem Hintergrundbild an der 1000 px Grenze ist. Somit wird das perfekt weitergeführt und man sieht kein Kacheln mehr.
    5. Dasselbe funktioniert natürlich auch mit dem Seitenhintergrund, der in meinem Beispiel ja ein extra Hintergrundbild hat. Ich führe also zwei Hintergrundbilder nach unten ins unendliche.


    Alles klar jetze ?

    klar geht das. Haste mich hier überhaupt richtig verstanden?


    Alternative: Wenn du mit dem Stift um die Person fertig bist, dann stell sicher, dass du dafür ne einfarbige, weiße Füllung hast und der Pfad über der Person ist, nicht dahinter. Markier Pfad und Bild und gruppier das ganze als Maske. Das kannste dann einfach mit Modifizieren/In Bitmap konvertieren und der Hintergrund ist weg.


    Anmerkung: Freistellen mit Bitmapmasken ist besser als mit den handelsüblichen Werkzeugen. Grund: In Bitmapmasken kannst du mit dem Pinsel malen wie in einem Bild und jederzeit korrigieren. Dabei zeigt weiß und schwarz verdeckt. In FW 4 war schwarz/weiß bissel vertauscht, aber das tut der Funktionalität ja keinen Abbruch.


    So gehts: Bild markieren und über das Symbol im Ebenenbedienfeld eine Bitmapmaske einfügen. FW legt über das gesamte Bild eine Maske. Diese markierst du im Ebenenbedienfeld und kannst dann mit schwarzem und weißem Pinsel den Hintergrund weg-"radieren" oder zuviel mit der Gegenfarbe wieder korrigieren. Ebenso greifen natürlich auch alle Pinseloptionen wie Opazität, Rand, Pinselstrich usw. Der Pinsel wirkt bei einer Bitmapmaske ähnlich wie der Radiergummi. So kann man ganz exakt freistellen. Macht natürlich auch bissel mehr Arbeit, klar. Zum Schluss kannste das ganze wieder in ein Bitmap konvertieren und die Maske mitsamt dem Hintergrund is weg.


    Und sag nich wieder - das geht nich. Wenn, dann sag uns wo's bei dir hängt;)


    Gruß Andi

    1.wie wärs denn mit Modifizieren/In Bitmap konvertieren (FW4) bzw. Auswahl als Hintergrund (seit MX). Schon ist der Pfad ein Bitmap.
    2. Dann mit gehaltener STRG Taste auf das Ebenenpic im Ebenenbedienfeld klicken und der Auswahlrahmen läuft.


    PS. zu 2. Manchmal entfällt mir auch was und kanns grad nich testen. Kann auch mit gehaltener Alt oder Umschalttaste sein. Sowas wird öfter mal geändert.


    Gruß Andi

    ich blicks auch nich so richtig. Hab aber auch nicht die PNG angesehen, schon zu spät dafürcaipi


    Sieht jedenfalls aus wie das Wellenmuster und darum gehts wohl?


    Wenn die Farben nicht mit angrenzenden Objekten übereinstimmen, so kannst du erstmal versuchen im Farbverlauf des jeweiligen Objektes einzelne Farben anzupassen (Füllung bearbeiten). Dort hast du paar Regler und kannst jedem einzelnen eine beliebige Farbe zuweisen. Das verschieben der Regler hat auch nicht wenig Auswirkung. Es lassen sich mit Linksklick auch neue Regler setzen.


    Ebenso kannst du jedem Regler, also jeder Farbe, sagen, wieviel Transparenz die haben soll. Das sind dann die Regler über den Farbreglern;) So sollte es nicht schwer fallen die Farben anzugleichen.


    Es gibt noch ne Menge andere Möglichkeiten mit (Verlaufs)-Mustern passender zu hantieren unter anderem gehts da in die Richtung - Maskentechnik -, und da weiß ich jetzt nicht, ob dich das etwas überfordern würde. Ist nicht böse gemeint, aber versuchs erstmal mit der Anpassung des normalen Farbverlaufs:) Jedenfalls über die Opazität des Objektes selber ist das keine gute Lösung. Es sei denn, du legst dahinter genau passend ein zweites einfarbiges Rechteck. Das schein ja dann durch und das kannste nach Bedarf ja dunkler oder heller machen.


    Gruß Andi

    Bei sowas wäre es immer besser, wenn du den Quelltext oder ein Onlinevariante des Problems zur Verfügung stellst, sonst kann man nur raten. Paar Anhaltspunkte bis dahin...


    1. heißt in Dreamweaver der Frame - wo der Link geöffnet werden soll - überhaupt _mainFrame?
    2. Verhindern evtl. deine Browsereinstellungen, dass externe Links in Framesets geöffnet werden?
    3. Schon mal mit nem anderen Browser getestet?


    Wie gesagt, wir brauchen schon bissel was zum anfassen für die Fehlersuche;) Von der Fireworksseite ist die Sache meiner Meinung nach OK.


    Gruß Andi