Beiträge von Zockratte

    Hallo zusammen,


    ich bin leider immernoch nicht viel weiter und muss euch einfach nochmal "belästigen".


    Ich kann den Fehler soweit reproduzieren, dass ich zumindestens eine Logik dahinter sehe.


    Ausgangslage:
    Ich habe 3 selects und bei allen mehrere options.
    Solange ich nur in einem select eine Auswahl treffe gibt einen reload und die entsprechende option ist "selected". alle anderen options sind nach wie vor wählbar. Das kann ich den ganzen Tag machen egal welches select ich anfasse -> soweit funktionierts.


    Habe ich jetzt aber in einem select eine option gewählt und wähle in einem anderen select eine option, reduziert sich das select in dem ich bereits eine Auswahl getroffen habe eben auf diese ausgewählte option. Alle anderen options sind nicht mehr da.


    Macht diese Abhängigkeit überhaupt einen Sinn?


    langsam bin ich reif dür die Selbsthilfegruppe ... :(

    Lies dir einfach mal in Ruhe die Inhalte der oben geposteten Links durch. Mehr kann man kaum noch sagen.


    Man kann Tabellen nicht in CSS umwandeln. CSS sind die Beschreibungen der Elemente die du beim Erstellen deines HTML-Dokuments benutzt.


    Es geht darum, das du ein Element so benutzt wie es seine "Erfinder" vorgesehen haben. Eine Überschrift ist eine Überschrift und hat eine bestimmte Funktion. Eine Tabelle ebenso. Diese ist für die Darstellung tabellarischer Daten da und nicht zum zusammenhalten deines Layouts. D.h. willst du eine Übersicht von Veranstalltungsterminen online stellen nimmst du eine Tabelle. willst du dein Layout positionieren nimmst du keine Tabelle.

    Hallo!


    Google interessiert mehr als nur der <head>
    Hier sind meines Wissens nur die Description (ganz doll) und die Keywords (weniger) wichtig.


    Dazu kommt aber noch der Rest des Dokuments, also der Teil der im <body> steht.


    Das Dokument muss sauber strukturiert werden - Stichwort "Semantik".
    Also z. B. Überschriften mit H1 oder H2 ... auszeichnen und nicht mit Schriftgröße und Farbe über Stile optisch hervorheben.


    Dazu kannst du deinen Bilder z.B. Alt- und Titel-Tags mitgeben. Alles das ist am Ende Futter für die hungrigen Suchmaschinen.


    Gib uns doch mal ein Beispiel für ein komplette Seite. Daran kann man das besser verdeutlichen.

    li:hover <-------- das versteht der IE mMn nicht. hier gibts ein Javascript was dem IE diese Eigenschaft beibiegt. hast du das?




    bin grad etwas in Zeitnot, könnte später nochmal konkret nachsehen. ich habe irgend ein Projekt mal mit so einem Menü gebaut. *such*



    edit: Google sagt das der 6er IE das nicht kann der 7 + höher schon.
    Ich kann heute am späten abend nochmal reinsehen. Wenns schneller gehen soll fragst du vllt auch mal Google :D



    edit Nr. 2:
    Ich finde mein Bsp. nicht aber hier ist es erklärt. http://www.xs4all.nl/~peterned/csshover.html
    Bei Unklarheiten einfach nochmal posten...

    so langsam werde ich warm mit der Extension ...


    nur eines hindert mich momentan am Weiterkommen.


    Ich habe Produkte mit mehreren Eigenschaften (z.B. Farbe [rot, braun, grün] und Größe [M, L, XL])


    Ich möchte das über selects lösen und habe in der Detailansicht jetzt zwei davon. Eines mit den Größen und eines mit den Farben. In jedem select kommt zu den Werten noch ein Wert "ALLE" dazu. wenn ich jetzt in einem select einen Wert auswähle sind plötzlich in den anderen selects nicht mehr alle werte verfügbar. Ich muss einmal den Wert "Alle" wählen um die vollständigen Werte in den selects wieder herzustellen.
    Ich würde auch gerne diesen Alle-Wert löschen - habe ich schon gemacht, klappt auch solange ich nur ein select zum Produkt habe. habe ich mehrere kann ich die Werte nicht wieder zurücksetzen.


    Schwer zu erklären und anscheinend noch schwrer zu lösen... Weiß jemand mehr als ich zu diesem Thema?

    tidy habe ich meines Wissens nicht.
    DocHeader? meinst du den?:

    Code
    1. <!DOCTYPE html
    2. PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">


    den setzt Typo3 - in der index.htm (Template) steht ein anderer
    Das sehe ich gerade zu ersten mal ...


    ich habe jetzt erstmal in der class.tx_commerce_pibase.php


    Code
    1. ini_get('arg_separator.output')

    gegen ein einfaches "&" ersetzt. Das funktioniert ist aber sicher keine saubere Lösung.


    Das nächste Problem ist nämlich die Navigation.
    Hier sind die "&" in den Links auch wieder doppel umgewandelt - also zu "&amp;amp"

    so jetzt antworte ich mir mal selbst:


    Problem erkannt:


    Das geht nicht:
    typo3/index.php?id=10&amp;tx_commerce_pi1[catUid]=6&amp;cHash=0ea9ae6159



    Das geht:
    typo3/index.php?id=10&tx_commerce_pi1[catUid]=6&cHash=0ea9ae6159



    Kann mir jemand sagen wieso Typo3 die "&" umschreibt und wo ich das generell abstellen kann? Bei einer anderen Extension haben wir das Problem auch gehabt und die URLs direkt in den Templates angepasst. Da es jetzt wieder auftritt scheint es ein generelles Problem zu sein - oder?

    also ich habe ein root-template da steht halt das übliche drin. speziell zum Shop steht aber nix drin - war der Meinung das ist für diesen Step nicht nötig.


    Artikel habe ich erzeugt. nur eine Hand voll aber es sollte reichen um zumindest mal eine Ausgabe zu erzeugen.


    Wenn ich über Seite -> [9] Details gehe und den Seiteninhalt (plugin Commerce Produkt Liste) unter Detailprodukt (für Singleansicht): gehe,habe ich ein dropdown mit meinen Artikeln. Wähle ich einen davon aus wird immer wenn ich auf irgend eine Kategorie klicke dieser Artikel angezeigt.


    prinzipiell schein es zu funktionieren ... nur scheint irgendwo eine Einstellung nicht zu stimmen.

    jetzt muss ich ganz blöd fragen:


    muss die config ins roottemplate?


    muss ich überhaupt igendwas (nach schritt 1-21) tun um mir ganz simpel die Artikel anzeigen zu lassen. oder sollte ich zumindestens nach Schrit 21 die Kategorien und Artikel sehen. Ich weiß inzischen nicht mehr wo ich ansetzen muss.


    Ich habe bisher nix direkt in TS geschrieben.


    Habe ich hier grundsätzlich was vergessen/übersehen?!

    Hallo zusammen,


    folgendes Problem bringt mich um Schlaf und Verstand:


    Ich habe die Extension Commerce lt. der (einzigen?) im Netz verfügbaren Anleitung installiert und konfiguriert. Klicke ich jetzt auf Shop, werden alle Kategorien angezeigt und darunter ist eine leere Tabelle.
    Klicke ich auf eine Kategorie passiert nichts anderes.


    Ich sehe also keine Artikel.



    Das einzige was ich nicht gemacht habe, ist Frontend-Usergrups anzulegen. Kann es daran liegen?!


    edit: habe jetzt auch die FE_Usergroups angelegt -> weiterhin fehlanzeige.



    Was mir auffällt, wen ich auf Shop klicke steht im Inhalt:


    Produktkatalog
    Kategorie 1 -> verlinkt mit typo3/index.php?id=9&amp;tx_commerce_pi1[catUid]=6&cHash=.....
    Kategorie 2 -> verlinkt mit typo3/index.php?id=9&amp;tx_commerce_pi1[catUid]=3&cHash=.....
    Tabelle ...


    wenn ich jetzt auf Kategirie 1 oder 2 klicke steht im Inhalt:



    Produktkatalog
    Kategorie 1 -> verlinkt mit typo3/index.php?id=10&amp;tx_commerce_pi1[catUid]=6&cHash=.....
    Kategorie 2 -> verlinkt mit typo3/index.php?id=10&amp;tx_commerce_pi1[catUid]=3&cHash=.....
    Tabelle ...


    bis auf die ID ist alles gleich ....



    So sieht meine Struktur aus:
    # [2] Shop


    * [10] Produktliste
    * [9] Details
    * [8] Warenkorb
    * [7] Bestellung
    * [6] Adressmanagement
    * [5] Rechnung
    * [4] Content leerer Warenkorb
    * [3] Content leerer Checkout
    * [11] User
    * [12] Adressen



    was kann ich falsch gemacht haben??

    Zitat

    Solange Microsoft noch keinen Patch bereitstellt, sollte man zu einem alternativen Browser greifen, der die verwundbaren Microsoft-Bibliotheken nicht benutzt. Populäre Beispiele sind Firefox, Opera oder Safari.


    Das ist doch eine beruhigende Aussage. Ich nutze den nur noch zum Browsercheck ... zum surfen in unbekannten Gewässern ist mir das Ding schon lange zu heiß!



    edit: gutes Beispiel für falsch platzierte Werbung - eben stand zwischen unseren Posts:

    Zitat

    Hier: Internet Explorer 8
    www . microsoft.com/internet_explorer Mehr Sicherheit, mehr Komfort mit dem neuen Internet Explorer 8!


    Klasse! :D